document requirements
authorPhilipp Kern <pkern@debian.org>
Fri, 23 May 2008 09:09:47 +0000 (11:09 +0200)
committerPhilipp Kern <pkern@debian.org>
Fri, 23 May 2008 09:09:47 +0000 (11:09 +0200)
projects/usersync.mdwn

index 1129723..a812246 100644 (file)
@@ -6,6 +6,13 @@ The script also tracks which users where added or removed since the last run and
 
 The configuration system of this package might not yet be suitable for general use and examples for proper usage of the script might be missing.
 
+### Requirements
+
+Perl, module DBI and module File::Slurp are required for the script to run.
+The acl binaries are optional and can be used to restrict the access
+to ``authorized_keys``.  To authenticate against the files produced
+by usersync the db module for NSS is needed.
+
 ### How to get it
 
 The [source code repository](/cgi-bin/gitweb.cgi?p=usersync.git;a=summary) is available using [git](http://git.or.cz/) by running "``git clone git://opensource.fsmi.uni-karlsruhe.de/git/usersync.git``".  Debian packages for Debian Etch are available in [our repository](http://debian.fsmi.uni-karlsruhe.de/pool/main/u/usersync/) as well as the most current release tarball.